Excel Office 360: 1004 error only occurs on a specific work station

Utterly baffled here: I have an Exel VBA macro that works fine unless I am on a particular laptop as follows:

If I open the program on my ROG laptop and run the macro (which loads a userform), everything works fine. However, If I for any reason open the VBA project editor via “Alt F11” and then close the editor (even if I make no changes), when I subsequently attemp to run the macro, I get a 1004 error. This DOESN’T occur if I do the exact same thing on alternate workstations. So here is a breakdown:

 

On Asus ROG laptop (16g of memory available):

Excel Version: 1710 Build 8625.2121 (Click to Run)

VBA version 16.0

Win 7 Ultimate 64 

1) Open and run macro no problem

2) Access the VBA editor, make NO changes, close the editor

3) Run Macro–get 1004 error

 

Same sequence on my other laptop: (6g of memory available):

Excel Version: 1710 Build 8625.2121 (Click to Run)

VBA version 16.0

Win 10 Home 64

1) Open and run macro no problem

2) Access the VBA editor, make NO changes, close the editor

3) Run Macro–no problems at all.

 

Same sequence on my office desktop: (6g of memory available):

Excel Version: 1705 Build 8201.2200 (Click to Run)

VBA version 16.0

1) Open and run macro no problem

2) Access the VBA editor, make NO changes, close the editor

3) Run Macro–no problems at all.

 

Here’s what I have done for troubleshooting:

Full reinstall on Office 365

Removed all Excel addins

Opened the file in safe mode

Ran scannow; no errors were found

 

None of these actions has helped. I’m hoping that maybe someone has run into something similar and can point me in the right direction.

Thanks for looking

 

By: aj coughlin

Leave a Reply

Your email address will not be published. Required fields are marked *